$re = '/class="(.*?)"|id="(.*?)"/ms';
$str = '<pre class="code-class" id="code-error">
function error_notice() {
?>
<div class="error notice">
<p><?php _e( \'There has been an error\', \'my_textdomain\' ); ?></p>
</div>
<?php
}
add_action( \'admin_notices\', \'my_error_notice\' );
</pre>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);