import re
regex = re.compile(r"class=\"(.*?)\"|id=\"(.*?)\"", flags=re.MULTILINE | re.DOTALL)
test_str = ("<pre class=\"code-class\" id=\"code-error\">\n"
"function error_notice() {\n"
" ?>\n"
" <div class=\"error notice\">\n"
" <p><?php _e( 'There has been an error', 'my_textdomain' ); ?></p>\n"
" </div>\n"
" <?php\n"
"}\n"
"add_action( 'admin_notices', 'my_error_notice' );\n"
"</pre>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")