package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<device>[^ ]+)\s+\w+\s+\w+\s+\w+\s+\w+\s+(?<disk>\d+)`)
var str = `/dev/nvme4n1p1 xfs 50G 555M 50G 2% 25M 33K 25M 1% /var/www`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}