const regex = /^(?<device>[^ ]+)\s+\w+\s+\w+\s+\w+\s+\w+\s+(?<disk>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<device>[^ ]+)\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+(?<disk>\\d+)', 'gm')
const str = `/dev/nvme4n1p1 xfs 50G 555M 50G 2% 25M 33K 25M 1% /var/www`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}