import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<device>[^ ]+)\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+(?<disk>\\d+)";
final String string = "/dev/nvme4n1p1 xfs 50G 555M 50G 2% 25M 33K 25M 1% /var/www";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}