#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[^p\s]\w+"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"I must use regex to select all words that doesn't start with letter "p". For example:" & @CRLF & _
"" & @CRLF & _
"book, laptop, promise" & @CRLF & _
"" & @CRLF & _
"So, the regex formula must select only book, laptop" & @CRLF & _
"" & @CRLF & _
"My formula doesn't work, don't know why:" & @CRLF & _
"" & @CRLF & _
"FIND: \b(?!p)\w+\b OR \b(?!p){1}\w+\b OR \b(?![p])\w+\b" & @CRLF & _
"" & @CRLF & _
"My formulas selects also some single letters, but not just words \w+" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")