using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[^p\s]\w+";
string input = @"
I must use regex to select all words that doesn't start with letter ""p"". For example:
book, laptop, promise
So, the regex formula must select only book, laptop
My formula doesn't work, don't know why:
FIND: \b(?!p)\w+\b OR \b(?!p){1}\w+\b OR \b(?![p])\w+\b
My formulas selects also some single letters, but not just words \w+
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}