package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)\b[^p\s]\w+`)
    var str = `
I must use regex to select all words that doesn't start with letter "p". For example:
book, laptop, promise
So, the regex formula must select only book, laptop
My formula doesn't work, don't know why:
FIND: \b(?!p)\w+\b OR \b(?!p){1}\w+\b OR \b(?![p])\w+\b
My formulas selects also some single letters, but not just words \w+
`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}