#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^\S\r\n]*(\S+)[ \t]+(\S+)[ \t]+(\S+(?:[^\S\r\n]*\S+)*)"
Local $sString = " FOO 100 BOR " & @CRLF & _
" PAL 350 PIL " & @CRLF & _
" KIL 090 KUP" & @CRLF & _
" FAS 130 FOO's BAR" & @CRLF & _
" FAO 120 Pizza's joy poy"
Local $sSubst = "array($2, "$1", "$3"),"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)