import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^[^\\S\\r\\n]*(\\S+)[ \\t]+(\\S+)[ \\t]+(\\S+(?:[^\\S\\r\\n]*\\S+)*)";
final String string = " FOO 100 BOR \n"
+ " PAL 350 PIL \n"
+ " KIL 090 KUP\n"
+ " FAS 130 FOO's BAR\n"
+ " FAO 120 Pizza's joy poy";
final String subst = "array($2, \"$1\", \"$3\"),";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}