$re = '/(?m)^[^\S\r\n]*(\S+)[ \t]+(\S+)[ \t]+(\S+(?:[^\S\r\n]*\S+)*)/';
$str = ' FOO 100 BOR
PAL 350 PIL
KIL 090 KUP
FAS 130 FOO\'s BAR
FAO 120 Pizza\'s joy poy';
$subst = "array($2, \"$1\", \"$3\"),";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;