# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^[^\S\r\n]*(\S+)[ \t]+(\S+)[ \t]+(\S+(?:[^\S\r\n]*\S+)*)"
test_str = (" FOO 100 BOR \n"
" PAL 350 PIL \n"
" KIL 090 KUP\n"
" FAS 130 FOO's BAR\n"
" FAO 120 Pizza's joy poy")
subst = "array($2, \"$1\", \"$3\"),"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.