#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\|(\d+)\b(?<=\b(?=\|?\1\b).{1,999}?\|\d{1,9})"
Local $sString = "0612|0613|061|0612|0612" & @CRLF & _
"0211|0612|021|0212|0211|0211" & @CRLF & _
"0111|0111" & @CRLF & _
"0511|0512|0511|0511|0521|0512|0511" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)