# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\|(\d+)\b(?<=\b(?=\|?\1\b).{1,999}?\|\d{1,9})"
test_str = ("0612|0613|061|0612|0612\n"
"0211|0612|021|0212|0211|0211\n"
"0111|0111\n"
"0511|0512|0511|0511|0521|0512|0511\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.