# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(> \[!anki]- .+(?:\n(?!<!--).+)*)(?:\n<!-- end of flashcard -->)?/$1\n<!-- end of flashcard -->/g;t' <<< "> [!anki]- Title
> Answer
> [!anki]- Title
> Answer
<!-- end of flashcard -->
> [!anki]- Title
> Answer
> Another line
> Another line
> [!anki]- Title
> Answer
^7a6a36"