use strict;
my $str = '> [!anki]- Title
> Answer
> [!anki]- Title
> Answer
<!-- end of flashcard -->
> [!anki]- Title
> Answer
> Another line
> Another line
> [!anki]- Title
> Answer
^7a6a36';
my $regex = qr/(> \[!anki]- .+(?:\n(?!<!--).+)*)(?:\n<!-- end of flashcard -->)?/p;
my $subst = '$1\\n<!-- end of flashcard -->';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";