const regex = /(> \[!anki]- .+(?:\n(?!<!--).+)*)(?:\n<!-- end of flashcard -->)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(> \\[!anki]- .+(?:\\n(?!<!--).+)*)(?:\\n<!-- end of flashcard -->)?', 'g')
const str = `> [!anki]- Title
> Answer
> [!anki]- Title
> Answer
<!-- end of flashcard -->
> [!anki]- Title
> Answer
> Another line
> Another line
> [!anki]- Title
> Answer
^7a6a36`;
const subst = `$1\n<!-- end of flashcard -->`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);