# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\|(?=\|)/| /gm;t' <<< "|1.774|1.78|1|||||1.781|1||||||||"