#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\|(?=\|)"
Local $sString = "|1.774|1.78|1|||||1.781|1||||||||"
Local $sSubst = "| "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)