use strict;
my $str = '|1.774|1.78|1|||||1.781|1||||||||';
my $regex = qr/\|(?=\|)/mp;
my $subst = '| ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";