const regex = /\|(?=\|)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|(?=\\|)', 'gm')
const str = `|1.774|1.78|1|||||1.781|1||||||||`;
const subst = `| `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);