#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[;#%|*]([\s\S].*?)(?=[\r\n])"
Local $sString = "# This is a multiple line comment" & @CRLF & _
"# This is a multiple line comment" & @CRLF & _
"# which is just a block of single line comments" & @CRLF & _
"# that are strung together" & @CRLF & _
"" & @CRLF & _
"not comment" & @CRLF & _
"not comment" & @CRLF & _
"not comment" & @CRLF & _
" " & @CRLF & _
"# This is a multiple line comment" & @CRLF & _
"# This is a multiple line comment" & @CRLF & _
"# which is just a block of single line comments" & @CRLF & _
"# that are strung together" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")