import Foundation
let pattern = ##"[;#%|*]([\s\S].*?)(?=[\r\n])"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# This is a multiple line comment
# This is a multiple line comment
# which is just a block of single line comments
# that are strung together
not comment
not comment
not comment
# This is a multiple line comment
# This is a multiple line comment
# which is just a block of single line comments
# that are strung together
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)