re = /[;#%|*]([\s\S].*?)(?=[\r\n])/m
str = '# This is a multiple line comment
# This is a multiple line comment
# which is just a block of single line comments
# that are strung together
not comment
not comment
not comment
# This is a multiple line comment
# This is a multiple line comment
# which is just a block of single line comments
# that are strung together
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end