$re = '/[;#%|*]([\s\S].*?)(?=[\r\n])/m';
$str = '# This is a multiple line comment
# This is a multiple line comment
# which is just a block of single line comments
# that are strung together
not comment
not comment
not comment
# This is a multiple line comment
# This is a multiple line comment
# which is just a block of single line comments
# that are strung together
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);