package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/stage.in.app.com\/usert\/[^\s,]+\b[\"\']`)
var str = `[https://stage.in.app.com/usert/123cccfefwerio123i12o3ij1o2i312n3">https://stage.in.app.com/usert/123cccfefwerio123i12o3ij1o2i312n3</a]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}