// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)https:\/\/stage.in.app.com\/usert\/[^\s,]+\b[\"\']"#).unwrap();
let string = "[https://stage.in.app.com/usert/123cccfefwerio123i12o3ij1o2i312n3\">https://stage.in.app.com/usert/123cccfefwerio123i12o3ij1o2i312n3</a]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}