import Foundation
let pattern = #"https:\/\/stage.in.app.com\/usert\/[^\s,]+\b[\"\']"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[https://stage.in.app.com/usert/123cccfefwerio123i12o3ij1o2i312n3">https://stage.in.app.com/usert/123cccfefwerio123i12o3ij1o2i312n3</a]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)