#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\babc\b(?! abc\b).*?\b123\b"
Local $sString = "abc abc abc efg 123 abc 123 abc abc xyz 123" & @CRLF & _
"" & @CRLF & _
"abc abc abc efg 123 abcd 123 abc abc xyz 123 abc abcd 123" & @CRLF & _
"" & @CRLF & _
"abc efg abc 123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")