const regex = new RegExp('\\babc\\b(?! abc\\b).*?\\b123\\b', 'gm')
const str = `abc abc abc efg 123 abc 123 abc abc xyz 123
abc abc abc efg 123 abcd 123 abc abc xyz 123 abc abcd 123
abc efg abc 123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}