using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\babc\b(?! abc\b).*?\b123\b";
string input = @"abc abc abc efg 123 abc 123 abc abc xyz 123
abc abc abc efg 123 abcd 123 abc abc xyz 123 abc abcd 123
abc efg abc 123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}