$re = '/\babc\b(?! abc\b).*?\b123\b/m';
$str = 'abc abc abc efg 123 abc 123 abc abc xyz 123
abc abc abc efg 123 abcd 123 abc abc xyz 123 abc abcd 123
abc efg abc 123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);