#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:[^\x00-\x7F]|[a-zA-Z]\s*)+)(\d+\/\d{2})"
Local $sString = "Ericsson Sistemas de Energia Ltda 1029384756/00" & @CRLF & _
"Ericsson Telecomunicações 0192837465/00" & @CRLF & _
"Telefônica do Brasil Ltda 5647382910/00" & @CRLF & _
"Tim do Brasil Ltda 3669278723/00" & @CRLF & _
"Telemar Telecomunicações Ltda 5463782113/00" & @CRLF & _
"Vivo do Brasil Ltda 7588697132/00" & @CRLF & _
"Oi Telecomunicações Ltda 1253467264/00" & @CRLF & _
"Claro do Brasil Ltda 0980966535/00" & @CRLF & _
"Telecomunicações Ltda 3562989272/00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")