# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:[^\x00-\x7F]|[a-zA-Z]\s*)+)(\d+\/\d{2})"
test_str = ("Ericsson Sistemas de Energia Ltda 1029384756/00\n"
"Ericsson Telecomunicações 0192837465/00\n"
"Telefônica do Brasil Ltda 5647382910/00\n"
"Tim do Brasil Ltda 3669278723/00\n"
"Telemar Telecomunicações Ltda 5463782113/00\n"
"Vivo do Brasil Ltda 7588697132/00\n"
"Oi Telecomunicações Ltda 1253467264/00\n"
"Claro do Brasil Ltda 0980966535/00\n"
"Telecomunicações Ltda 3562989272/00")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.