import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[^\\x00-\\x7F]|[a-zA-Z]\\s*)+)(\\d+\\/\\d{2})";
final String string = "Ericsson Sistemas de Energia Ltda 1029384756/00\n"
+ "Ericsson Telecomunicações 0192837465/00\n"
+ "Telefônica do Brasil Ltda 5647382910/00\n"
+ "Tim do Brasil Ltda 3669278723/00\n"
+ "Telemar Telecomunicações Ltda 5463782113/00\n"
+ "Vivo do Brasil Ltda 7588697132/00\n"
+ "Oi Telecomunicações Ltda 1253467264/00\n"
+ "Claro do Brasil Ltda 0980966535/00\n"
+ "Telecomunicações Ltda 3562989272/00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}