import Foundation
let pattern = #"((?:[^\x00-\x7F]|[a-zA-Z]\s*)+)(\d+\/\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Ericsson Sistemas de Energia Ltda 1029384756/00
Ericsson Telecomunicações 0192837465/00
Telefônica do Brasil Ltda 5647382910/00
Tim do Brasil Ltda 3669278723/00
Telemar Telecomunicações Ltda 5463782113/00
Vivo do Brasil Ltda 7588697132/00
Oi Telecomunicações Ltda 1253467264/00
Claro do Brasil Ltda 0980966535/00
Telecomunicações Ltda 3562989272/00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)