using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)(\h+)(\(\w+\))";
string substitution = @"$3$2$1";
string input = @"abcd<ef>efgh (FO)<ef>kl (OF)
xyz<ef>mno
pwr<ef>hijkl (FO)<ef>dfg (OF)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}