// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+)(\h+)(\(\w+\))").unwrap();
let string = "abcd<ef>efgh (FO)<ef>kl (OF)
xyz<ef>mno
pwr<ef>hijkl (FO)<ef>dfg (OF)";
let substitution = "$3$2$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}