$re = '/(\w+)(\h+)(\(\w+\))/m';
$str = 'abcd<ef>efgh (FO)<ef>kl (OF)
xyz<ef>mno
pwr<ef>hijkl (FO)<ef>dfg (OF)';
$subst = "$3$2$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;