use strict;
my $str = 'abcd<ef>efgh (FO)<ef>kl (OF)
xyz<ef>mno
pwr<ef>hijkl (FO)<ef>dfg (OF)';
my $regex = qr/(\w+)(\h+)(\(\w+\))/mp;
my $subst = '$3$2$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";