const regex = /^(?!xxx-)(?![^@]+@test\.com$)[^@]+@[^@\n]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!xxx-)(?![^@]+@test\\.com$)[^@]+@[^@\\n]+$', 'gm')
const str = `abc@email.com
xxx-123@domain.com
abc.123@test.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}