re = /^(?!xxx-)(?![^@]+@test\.com$)[^@]+@[^@\n]+$/m
str = 'abc@email.com
xxx-123@domain.com
abc.123@test.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end