$re = '/^(?!xxx-)(?![^@]+@test\.com$)[^@]+@[^@\n]+$/m';
$str = 'abc@email.com
xxx-123@domain.com
abc.123@test.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);