#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\d{1,2}([wp])(?:\d{1,2}(?!\1)[wp]\d{1,2}\1)*(?:\d{1,2}(?!\1)[wp])?$)\d{1,2}[wp]|(?!^)\G\d{1,2}[wp]"
Local $sString = "2w" & @CRLF & _
"1p" & @CRLF & _
"3w1p3w" & @CRLF & _
"2p12w2p3w" & @CRLF & _
"2p12p2w3p" & @CRLF & _
"2p121w2p3w" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")