import Foundation
let pattern = #"^(?=\d{1,2}([wp])(?:\d{1,2}(?!\1)[wp]\d{1,2}\1)*(?:\d{1,2}(?!\1)[wp])?$)\d{1,2}[wp]|(?!^)\G\d{1,2}[wp]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2w
1p
3w1p3w
2p12w2p3w
2p12p2w3p
2p121w2p3w
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)