using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\d{1,2}([wp])(?:\d{1,2}(?!\1)[wp]\d{1,2}\1)*(?:\d{1,2}(?!\1)[wp])?$)\d{1,2}[wp]|(?!^)\G\d{1,2}[wp]";
string input = @"2w
1p
3w1p3w
2p12w2p3w
2p12p2w3p
2p121w2p3w
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}