use strict;
my $str = '2w
1p
3w1p3w
2p12w2p3w
2p12p2w3p
2p121w2p3w
';
my $regex = qr/^(?=\d{1,2}([wp])(?:\d{1,2}(?!\1)[wp]\d{1,2}\1)*(?:\d{1,2}(?!\1)[wp])?$)\d{1,2}[wp]|(?!^)\G\d{1,2}[wp]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}