using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\(\""(.+?)\"",\""(.+?)\""\)(?:, ){0,1})";
string input = @"(""key"",""val""), (""key2"",""val\""2""), (""key3"",""val3"")";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}