package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\(\"(.+?)\",\"(.+?)\"\)(?:, ){0,1})`)
var str = `("key","val"), ("key2","val\"2"), ("key3","val3")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}