$re = '/(?:\(\"(.+?)\",\"(.+?)\"\)(?:, ){0,1})/';
$str = '("key","val"), ("key2","val\\"2"), ("key3","val3")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);